发新帖

[原创] 【树莓派3B+试用体验】POE功能的粗糙使用

[复制链接]
发表于 2018-6-3 16:42:56
| 16428 查看 | 7 回复
本帖最后由 pokebox 于 2018-6-3 16:44 编辑

首先感谢ICKEY提供的这次3B+试用机会。
树莓派3B+在上一代的基础上增加了POE供电的功能,但是目前还没有相应的模块能买到,官方也没有提供相关的硬件资料,那,只能自己先尝试一下了。
首先说说POE是干嘛的,POE(Power Over Ethernet是指在网络布线结构不做任何改动的情况下提供网络的同时提供电源的一个供电技术,这样的好处就是一根网线搞定设备的联网和电源,布线简单方便。
那么,要使用树莓派的POE功能,我们先来看看树莓派板子上那四个插针是干嘛用的。
到树莓派官网找到3B+的原理图,查看基本电路结构: POE_IO.png
可以看到这4个插针都是网口上网络变压器的中间抽头,同时也看到网络数据的输出和输入端是没有直接连接的,都是通过网络变压器转换后输出的数据。
只是图上标示的电路连接是总线出来的,可能看的有点迷,不知道具体是哪个口对应哪个抽头,那我们还是用万用表测一下比较好。 板子背面POE.jpg

用万用表导通测试网口的4个抽头对应的4Pin插头的数字引脚,因此这4个引脚只是抽头引出,不带其他功能。那么怎么去使用这4个引脚呢,首先我们来看看关于POE的一些接线图
POE_802.3at.gif
这是一张802.3at协议的POE供电接线示意图,这是个百兆的接法,使用了两对无数据的网线做供电使用,我们就参照这个图做实验。
首先从路由器或交换机迁出一根网线,然后给两对(蓝和棕对线4578)网线加电压,因为是测试,所以先使用3.3V的低电压接入。


我要点赞 0

举报

发表于 2018-6-3 16:47:37
本帖最后由 pokebox 于 2018-6-3 16:56 编辑

IMG_20180603_134226.jpg
这里我使用了一组RJ45的面板模块,这种模块是墙上网口面板里的那种接线模块,因为可以直接把线插进去使用,做测试也比较方便,我就用了它。然后用公头的杜邦线把两个模块按照示意图连接起来,网络输入的口只连接2组对线(12、36)直通另一个模块,做网络数据通讯,另外一个模块的两组对线(45、78)引出,做供电使用。
IMG_20180603_134443.jpg
连接到面包板上,然后找来一个USBTTL模块,带3.3V和5V电压输出的,先把3.3V接到其中一组对线上,GND接另一组对线,然后用网线把网口和树莓派连接起来
1528005255393.jpg
测量POE口的输出电压。因为要用一只手拿相机,单手不好拿表笔,就引出了一根杜邦线……嗯,3.3V,问题不大。
然后接上树莓派电源开机,看看树莓派有没有什么异常,也没有。OK,上5V然后直接从POE口接到树莓派的5VIO口上看看能不能开机。因为模块的供电能力弱,我就做了个micro口的转接板直接接5V的供电头测试。
1528005642017.jpg
为了方便查看电压,我还在背面焊上了个数字电压表,实时查看电压状态。
1528005851202.jpg
再次测量,同时确认好极性,发现有大概有0.7V的电压降。接上树莓派,发现可以开机,但是等待系统启动后发现,电压变化很大,从5.12V掉到4.88V以下然后树莓派就重启了,用万用表测量在启动过程中电流大概在600mA以上,看来直接5V供电并不是很可靠。
1528006208468.jpg



我要点赞 0

举报

发表于 2018-6-3 16:50:14
然后之前买过一个WiFi中继模块,用的就是POE供电,用的是12V,那么,我们也来试试12V供电。因为现在POE供电模块不在身边,就只能草草拿个12V电源来试试了。
身边有个给音响用的双12V变压器,还有个12V 100W的DC模块,相比之下用电源模块还是比较安心的,也不需要自己再去搭整流输出什么的。
IMG_20180602_212123.jpg IMG_20180602_212202.jpg IMG_20180602_212525.jpg
老规矩,测试输出电压,按刚才的接法接到树莓派上,测试POE的输出电压,12V,很好。
但是!!!现在千万 不要 直接把POE端的12V输出直接接到树莓派IO上,否则将烧毁树莓派!!


我要点赞 0

举报

发表于 2018-6-3 16:53:37
好了,12V输出,得想办法变成5V才行,粗糙的找两个DC-DC的降压模块,粗糙的焊了一堆排针,然后又粗糙的加了几个电容,上机把输出电压调整到5V左右,然后再测试……
IMG_20180602_212233.jpg
从树莓派的POE端取电,然后给DC降压模块,再测量输出电压,好了,现在可以从DC的输出端接到树莓派上了,再测试
IMG_20180602_212648.jpg 正常启动12VPOE.jpg
可以看到树莓派3B+的网口灯亮了,系统也正常能通过ssh访问进去了,不过电源指示灯还是提示电源存在异常,可能电流不够或者电压降的比较多吧,毕竟现在用的是杜邦线,杜邦线的线损其实是很大的,特别是一些质量一般的杜邦线,电流大的时候压降有时甚至可以达到2V……也许换一根粗一点的线或者用多根杜邦线并联起来会好一些。当然,我这只是做开拓性测试,剩下的大家可以自己去尝试~
正常12V开机.jpg
完整的运行图。(电脑上是树莓派3B+的htop运行画面)

由于直接一层楼编辑帖子发布存在502错误,所以采用分楼方式发表。

我要点赞 1

举报

发表于 2018-6-5 15:16:02
点个赞,写的很有用!
我要点赞 0

举报

发表于 2018-6-6 16:22:26
本帖最后由 pokebox 于 2018-6-6 16:32 编辑

更新一下,到学校拿到了POE电源,测量输出是15V的,并且把杜邦线换成了较短的硅胶线,网线也使用了带屏蔽的六类线,现在树莓派的电源指示灯常亮了,供电完全没问题了。说明这和导线质量的关系还是很大的。

图.jpg POE电源.jpg 完美运行.jpg

顺便试了试带摄像头负载,也完全没问题~
_353300238_1528273872773_1528273873000_wifi_0.jpg
我要点赞 1

举报

发表于 2018-6-12 16:59:54
很好的实验验证。
我要点赞 0

举报

发表于 2018-7-24 09:01:35
POE 供电是有协议的,单纯在那几根线上加电压肯定不好用。而且供电电压典型值是48V
我要点赞 0

举报

发表于 2019-9-11 16:10:06
pokebox 发表于 2018-6-6 16:22
更新一下,到学校拿到了POE电源,测量输出是15V的,并且把杜邦线换成了较短的硅胶线,网线也使用了带屏蔽的 ...

写得不错
我要点赞 0

举报

发表于 2019-9-11 16:11:45

向他学习
我要点赞 0

举报

您需要登录后才可以回帖 登录 | 立即注册